Temurin™ Supported Platforms

This section lists the operating systems that are supported with the latest release of Eclipse Temurin.

[check] - Supported, [docker] - Docker image available, [times] - Not supported

Operating System

Eclipse Temurin Version

  8

11

17

19

Windows (x64/x86)

Windows Server 2022

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Windows Server 2019

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Windows Server 2016

[check]

[check]

[check]

[check]

Windows Server 2012 R2

[check]

[check]

[check]

[check]

Windows 11

[check]

[check]

[check]

[check]

Windows 10

[check]

[check]

[check]

[check]

Windows 8.1

[check]

[check]

[check]

[check]

Linux (x64) [1]

Alpine Linux 3.5 or later (Headless)

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

RHEL 9.x

[check]

[check]

[check]

[check]

RHEL 8.x

[check]

[check]

[check]

[check]

RHEL / CentOS 7.x

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

SUSE Linux Enterprise Server (SLES) 12

[check]

[check]

[check]

[check]

Ubuntu 22.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 20.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 18.04

[check]

[check]

[check]

[check]

Linux (ARM 64-bit) [2]

RHEL 9.x

[check]

[check]

[check]

[check]

RHEL 8.x

[check]

[check]

[check]

[check]

RHEL / CentOS 7.x

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 22.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 20.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 18.04

[check]

[check]

[check]

[check]

Linux (ARM 32-bit Hard-Float) [2]

Ubuntu 22.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 20.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 18.04

[check]

[check]

[check]

[check]

Linux (PowerPC 64-bit Little Endian) [2]

RHEL 9.x

[check]

[check]

[check]

[check]

RHEL 8.x

[check]

[check]

[check]

[check]

RHEL / CentOS 7.x

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 22.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 20.04

[check] [docker]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 18.04

[check]

[check]

[check]

[check]

Linux (s390x) [2]

RHEL 9.x

[times] [3]

[check]

[check]

[check]

RHEL 8.x

[times] [3]

[check]

[check]

[check]

RHEL 7.x

[times] [3]

[check]

[check]

[check]

Ubuntu 22.04

[times] [3]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 20.04

[times] [3]

[check] [docker]

[check] [docker]

[check] [docker]

Ubuntu 18.04

[times] [3]

[check]

[check]

[check]

macOS (x64) [4]

macOS 12

[check]

[check]

[check]

[check]

macOS 11

[check]

[check]

[check]

[check]

macOS 10.15

[check]

[check]

[check]

[check]

macOS 10.14

[check]

[check]

[check]

[check]

macOS (Apple Silicon)

macOS 12

[times]

[check]

[check]

[check]

macOS 11

[times]

[check]

[check]

[check]

Solaris (x64 and Sparc)

Solaris 11

[check]

[times]

[times]

[times]

Solaris 10u11

[check]

[times]

[times]

[times]

AIX (PowerPC 64-bit Big Endian)

AIX 7.2

[check]

[check]

[check]

[check]

AIX 7.1 TL5 SP5

[check]

[check]

[check]

[check]

AIX 7.1 TL4

[check]

[check]

[check]

[check]


1. These builds should work on any distribution with glibc version 2.12 or higher.
2. These builds should work on any distribution with glibc version 2.17 or higher.
3. JDK8 on s390 has no JIT so is unsupported.
4. These builds should work on macOS 10.12 or higher.

Contributors

  • gdams
  •  karianna
  •  SueChaplain
  •  sxa
  •  KalyanJoseph
  •  sxa555
  •  ParkerM
  •  hendrikebbers
  •  aahlenst
  •  MBoegers
  •  luozhenyu
  •  tellison
Help us make these docs great!
All Adoptium docs are open source. See something that's wrong or unclear?
Edit this page