× 22nd Sept 2021 Eclipse Temurin 17 GA initial platforms are available!
You can track progress of additional platforms.

Supported Platforms

Temurin 8

Where available, binaries are supported on the minimum operating system levels shown in the following tables:

Key Value
HotSpot VM Hotspot VM

Linux x64
Centos 6.9 Hotspot VM
Centos 7.4 Hotspot VM
Centos 8 Hotspot VM
Red Hat Enterprise Linux (RHEL) 6.9 Hotspot VM
RHEL 7.4 Hotspot VM
RHEL 8 Hotspot VM
SUSE Linux Enterprise Server (SLES) 12 Hotspot VM
Ubuntu 16.04 Hotspot VM
Ubuntu 18.04 Hotspot VM
Ubuntu 20.04 Hotspot VM

Note: Any other Linux distributions that have a minimum glibc version 2.12 on x86, 2.23 on aarch32 and 2.17 on other architectures are expected to function without problems.

Windows x64
Windows 7 SP1 Hotspot VM
Windows 8 Hotspot VM
Windows 8.1 Hotspot VM
Windows 10 Hotspot VM
Windows Server 2012 Hotspot VM
Windows Server 2012 R2 Hotspot VM
Windows Server 2016 Hotspot VM
Windows Server 2019 Hotspot VM

macOS x64
OSX 10.10+ Hotspot VM

Temurin 11

Where available, binaries are supported on the minimum operating system levels shown in the following tables:

Key Value
HotSpot VM Hotspot VM

Linux x64
Centos 6.9 Hotspot VM
Centos 7.4 Hotspot VM
Centos 8 Hotspot VM
RHEL 6.9 Hotspot VM
RHEL 7.4 Hotspot VM
RHEL 8 Hotspot VM
SLES 12 Hotspot VM
Ubuntu 16.04 Hotspot VM
Ubuntu 18.04 Hotspot VM
Ubuntu 20.04 Hotspot VM

Windows x64
Windows 7 SP1 Hotspot VM
Windows 8 Hotspot VM
Windows 8.1 Hotspot VM
Windows 10 Hotspot VM
Windows Server 2012 Hotspot VM
Windows Server 2012 R2 Hotspot VM
Windows Server 2016 Hotspot VM
Windows Server 2019 Hotspot VM

macOS x64
OSX 10.10+ Hotspot VM


Temurin 16

Where available, binaries are supported on the minimum operating system levels shown in the following tables:

Key Value
HotSpot VM Hotspot VM

Linux x64
Centos 6.9 Hotspot VM
Centos 7.4 Hotspot VM
Centos 8 Hotspot VM
RHEL 6.9 Hotspot VM
RHEL 7.4 Hotspot VM
RHEL 8 Hotspot VM
SLES 12 Hotspot VM
Ubuntu 16.04 Hotspot VM
Ubuntu 18.04 Hotspot VM
Ubuntu 20.04 Hotspot VM

Windows x64
Windows 7 SP1 Hotspot VM
Windows 8 Hotspot VM
Windows 8.1 Hotspot VM
Windows 10 Hotspot VM
Windows Server 2012 Hotspot VM
Windows Server 2012 R2 Hotspot VM
Windows Server 2016 Hotspot VM
Windows Server 2019 Hotspot VM

macOS x64
OSX 10.10+ Hotspot VM

Support 

Submit an Issue